В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
HanZamay
HanZamay
22.03.2023 19:27 •  Информатика

Решить! 1)написать программу на паскале: вычислить длину орбиты земли.радиус орбиты земли равен 150 млн.км. 2)написать программу на паскале: прием на работу идёт на конкурсной основе.условия приема требуют 20 лет трудового стажа и возраста не более 45 лет.определить,будет ли человек принят на работу. 3))написать программу на паскале: вывести на экран все трехзначные числа ,сумма квадратов цифр которых равна 105.

Ответ:
трнвчполт755
трнвчполт755
02.10.2020 16:41
Program P1;
const
  R=150000000;
begin
  Writeln('Длина орбиты Земли составляет ',2*Pi*R:0:0,' км.')
end.

Результат выполнения программы:
Длина орбиты Земли составляет 942477796 км.

program p2;
var
  stazh,vozrast:integer;
begin
  Write('Введите через пробел стаж и возраст: ');
  Readln(stazh,vozrast);
  if (stazh>=20) and (vozrast<=45) then Writeln('Принимается')
  else Writeln('Не принимается')
end.

Тестовое решение:
Введите через пробел стаж и возраст: 23 50
Не принимается

program p3;
var
  i,j,k:integer;
begin
  for i:=1 to 9 do
    for j:=0 to 9 do
      for k:=0 to 9 do
        if sqr(i)+sqr(j)+sqr(k)=105
        then Write(i,j,k,' ')
end.
   
Результат выполнения программы:
458 485 548 584 845 854
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?