В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
dsokolovskiyp015em
dsokolovskiyp015em
22.08.2021 18:25 •  Информатика

Нужно составить программу в паскале.

дано натуральное число n> 1. вычислить s=1! +2! +3! +…+n!

Ответ:
IvanMiren
IvanMiren
02.10.2020 16:29

program fantscrin;

 var n,i,s,f:integer;

begin

 write('Введите N = '); readln(n);

 s:= 1;

 f:=1;

 for i:=2 to n do

 begin

   f:= f * i;

   s:=s + f;

 end;

 writeln('S = ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?