В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Нужно составить программу в паскале.

вычислить s=1! +2! +3! +…+n! используя подпрограмму-функцию вычисления факториала.

Ответ:
Elena9909
Elena9909
02.10.2020 16:29

var

n,x,a,s:longint;

begin

read(n);

a:=1;

for x:=1 to n do

begin

a:=a*x;

s:=s+a;

end;

writeln(a);

end.

Программа будет работать для n<=12, если надо больше, то меняйте тип переменных a и s на int64 / uint64

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?