В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kulimshina
Kulimshina
20.03.2021 11:26 •  Информатика

Нужно составить программу в паскале.

заполнить одномерный массив с клавиатуры, отсортировать его методом пузырька и вывести на экран.

Ответ:
айс1705
айс1705
02.10.2020 16:29

program fantscrin;

 const n = 10;

 var i,j:integer;

     a: array [1..100] of integer;

begin

 for i:=1 to n do

 begin

   write('a[',i,'] = ');

   readln(a[i]);

 end;

 

 for i:=1 to n do

   for j:=1 to n-1 do

     if a[j] > a[j+1] then swap(a[j], a[j+1]);

     

 for i:=1 to n do

   write(a[i],' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?