В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alex13536
alex13536
17.01.2020 19:13 •  Информатика

Нужно составить программу в паскале.

создать матрицу n-го порядка, вида:

Ответ:
khetagmuriev1
khetagmuriev1
24.07.2020 10:49

program raf105;

const

 n = 10;

var

 matrix: array[1..n,1..n] of integer;

begin

 for var i:=1 to n do

 begin

   for var j:=1 to n do

   begin

     if j = n-i+1 then

       matrix[i,j]:= i

     else

       matrix[i,j]:= 0;

     write(matrix[i,j]:3,' ');

   end;

   writeln;

 end;

end.

PascalABC
0,0(0 оценок)
Ответ:
Avenrop236
Avenrop236
24.07.2020 10:49

begin

 var m := ReadInteger();

 var a := MatrGen(m, m, (i, j)-> Ord(i + j = m - 1) * (i + 1));

 a.Println;

end.

Объяснение:


Нужно составить программу в паскале. создать матрицу n-го порядка, вида:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?