В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alsav241357
alsav241357
21.04.2020 13:07 •  Информатика

10 класс напишите программу обработки последовательности целых чисел. на вход программе сначала подается натуральное число n - кол-во элементов последовательности, n не превосходит 1000. затем следуют натуральные числа, каждое число в отдельной строке. каждый элемент последовательности не превосходит 10000. программа должна выводить все элементы последовательности, являющиеся трехзначными числами, кратными семи, в порядке, обратном порядке ввода. если таковых нет, программа выводит число -1 заранее !

Ответ:
dickosh97
dickosh97
02.10.2020 16:12
Program primer;
Var a:array[1..1000] of integer;
    i,m,k,n: integer;
Begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do begin  //в обратном порядке
k:=0;
m:=a[i];
while m>0 do begin
m:=m div 10;
inc(k);  // ищем количество разрядов 
end;
if ((a[i] mod 7) =0) and (k=3) then write(a[i]:2);//кратно 7 и 3 разряда - выводим
end;
end.
ABC Pascal
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?