В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olezhkash228
olezhkash228
30.10.2020 22:05 •  Информатика

Написать программу вывести элементы массива [90, 20, -40, -9, 0, 6, 12], которые меньше среднего арифметического всех элементов этого массива # код с урока # нахождение суммы положительных элементов массива # объявим массив (лист) mas = [90, 20, -40, -9, 0, 6, 12] # объявим переменную, которая будет копить сумму sum = 0 # узнаю длину массива l = len(mas) # объявляю индекс для прохода по массиву i = 0 # делаю обход массива, пока индекс меньше длины массива while i 0: sum += mas[i] i+=1 # вывести результат на экран print('сумма положительных элементов массива =', sum)

Ответ:
Тохо2004
Тохо2004
26.05.2020 05:47

a=[90, 20, -40, -9, 0, 6, 12]

mid=sum(a)/len(a)

for i in a:

 if i<mid:

     print(I)

s=0

a=[90, 20, -40, -9, 0, 6, 12]

for i in a:

if i>0:

  s+=i

print(s)

0,0(0 оценок)
Ответ:
OOAAAOO
OOAAAOO
26.05.2020 05:47

mass = [90, 20, -40, -9, 0, 6, 12]

sr = sum(mass) / len(mass)

for i in range (5):

   if  mass[i]<sr:

       print(mass[i])

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?