В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
akmal8606
akmal8606
23.06.2022 08:46 •  Информатика

Сделать ! напишите программу,которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа .количество введенных чисел неизвестно ,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность ).количество чисел не превышает 1000. введенные числа по модулю не превышают 30 000. программа должна вывести одно число: количество четных чисел,кратных 3 сделать ? ?

Ответ:
Настюша1118
Настюша1118
02.10.2020 16:05
Program a1;
var c,k,a: integer;
begin
a:=1;
while (a<>0) and (c<2)  do
begin 
read(a);
if (ABS(a)<30000) and (a<>0)  then
if ((a mod 2) = 0) and ((a mod 3)=0) then inc(k);
inc(c);
end;
writeln('kol = ',k);
end
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?