В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу в паскале. грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу,определяющею,догонит легковой автомобиль грузовой через t1 х после своего выезда

Ответ:
kryukova20023
kryukova20023
02.10.2020 15:43
 const     
v1 = 5; //Скорость грузовика     
v2 = 10;//Скорость легкового автомобиля     
t = 5;  //Задержка между выездом      

var   
t1 : integer; //Время, от выезда легкового авто  

begin 
readln (t1);   
if v1 * (t +t1) <= v2 * t1 then   
writeln ('Догонит')   
else    writeln ('Не догонит'); 
end.   

{ Уравнение зависимости координаты от времени 
x = xo + vt 
x0 = 0  

xg(t) = v1*(t+t1) 
xl(t) = v2*t1  

xl(t) >= xg(t) }
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?