Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
123456uiop
03.08.2021 21:46 •
Информатика
(pascal или delphi) в заданном массиве a(n) положительные элементы уменьшить вдвое, а отрицательные заменить на значения их индексов.
Ответ:
ichkinaeozrvu1
23.07.2020 18:26
Var a:array of real;
n,an:integer;
begin
randomize;
writeln('Введите размерность массива');
readln(n);
n:=n+1;
setlength(a,n);
for an:=1 to n-1 do
begin;
a[an]:=random(10);
if a[an]>0 then a[an]:=a[an]/2 else a[an]:=an;
write (a[an],',');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
2MaRiIa2
24.05.2023 10:39
Отдельное свойство объекта окружающего мира вызывает у нас: 1) представление 2) ощущение 3)...
vanyadrachuk2004
23.07.2020 21:40
Информатика 10 класс, ответить на Во Как заполнить массив случайными числами в диапазоне от 100 до 200...
НВТула
12.09.2022 03:05
ОЧЕНЬ НУЖНА БУДУ ОЧЕНЬ БЛАГОДАРЕН. 1)Сколько байт оперативной памяти будет занимать описанный массив? t: array [1..80] of boolean; Варианты ответов 160 10 0 80 2) Сколько элементов...
tatyanakarp
18.02.2023 14:37
Определите число N, для которого выполняется равенство 164N + 419 = 145N+2....
xrxrxrxrxr
30.01.2021 21:25
1.Составьте программу, которая вводит сумму и произведение натуральных чисел от 2 до 8 2.Составьте программу, которая вводит в порядке возрастания числа кратные трём в диапазоне...
aajlarov
06.07.2021 01:45
11. Якім членам сказа з яўляецца выдзеленае ў сказе слова? ДОБРА ўлетку ў пушчы.а) дзейник б)выказник в) дапауненне г) азначэнне д) акаличнасць...
Аня1ove
06.07.2021 01:45
Запишите 5 словосочетаний со словом золотой в прямом и переносном...
zakir2007
10.06.2021 02:28
Диагональ параллелограмма делит острый угол, из вершины которого она выходит, в отношении 1:3. Найди меньший из углов между этой диагональю и сторонами параллелограмма, если тупой...
umrina985
09.04.2022 08:49
. Read about Mike Miller and Kelly Smith. Compare their daily activities. What do you think who is busier? Make a list of tasks for each of them (a daily schedule).I’m an English...
kris3256567
09.04.2022 08:49
Карочеее, тут надо утверждение вопрос про усунов и кароче что-то так над...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n,an:integer;
begin
randomize;
writeln('Введите размерность массива');
readln(n);
n:=n+1;
setlength(a,n);
for an:=1 to n-1 do
begin;
a[an]:=random(10);
if a[an]>0 then a[an]:=a[an]/2 else a[an]:=an;
write (a[an],',');
end;
end.