В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Teddy1bear
Teddy1bear
09.03.2023 07:16 •  Информатика

Составить программу на языке паскаль, нахождение периметра и площади по трем сторонам( информатик сказал что нужно чтобы можно было выбирать или площадь или периметр) составить программу на языке паскаль по нахождение элементов одномерного массива заданное от 0 до 100 100

Ответ:
ulyanahoroshina
ulyanahoroshina
02.10.2020 15:37
Var
a,b,c,p,s:real;
m:integer;
begin
 repeat
   writeln('a,b,c &'); 
   readln(a,b,c); {Вводим стороны до тех пор пока не выполнится условие сущ треуг}
 until (a<b+c)and(b<a+c)and(c<a+b);
   writeln('площадь - введите 1 или периметр -2 ?');
{выбираем что считать, если площадь, то вводим 1, периметр - 2}
readln(m); 
   case m of   
     1:
        begin
            p:=(a+b+c)/2;
            writeln('S = ',sqrt(p*(p-a)*(p-b)*(p-c))); {вывод площади}
        end;
      2:writeln(a+b+c); {вывод периметра}
     end;
end.
     программа 2 Нахождение суммы элементов одномерного массива
const
n=10;
Var
a:array[1..n]of integer;
i,s:integer;
begin
   for i:=1 to n do
         begin
              a[i]:=random(100); {заполнение массива случайными числами [0.100)}
              write(a[i]:4); {выводим на экран массив}
              s:=s+a[i];   {считаем сумму}
         end;
writeln;
writeln('S= ',s); {выводим сумму}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?