В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Pascal уравнение написать программу решения уравнений вида (не обязательно квадратное) a*x^2 + b*x + c = 0. коэффициенты запрашиваются с экрана и могут быть любыми действительными числами. результатом работы программы является либо вывод корней уравнения, либо вывод какого-то сообщения. само уравнение тоже должно быть выведено на экран.

Ответ:
TaNyAmAkSiMeNkO
TaNyAmAkSiMeNkO
23.07.2020 16:50
Program a;
var D,a,b,c: real;
begin
Readln(a,b,c);
//a*X^2 + b*X + c = 0
writeln (a,'*X^2 + ',b,'*X + ',c,' = 0');
D:=b*b-4*c*a;
if (d<0) then writeln ('D<0!') else
if (d=0) then writeln ('X= ',(-b+sqrt(D))/2) else
if (d>0) then writeln ('X1= ',(-b+sqrt(D))/(2*a):0:1,'; X2= ',(-b-sqrt(D))/(2*a):0:1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?