В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Бос2017
Бос2017
10.10.2022 22:07 •  Информатика

(паскаль или delphi) написать программу поиска двухзначных чисел, удовлетворяющих следующему условию: если к сумме цифр числа прибавить квадрат этой суммы, то получится само число.

Ответ:
nastyaignatova3
nastyaignatova3
23.07.2020 16:22
Program z_3;
var a,b,n,s, i: integer;
Begin 
repeat  
writeln ('Введите Ваше число'); 
readln (n); 
if (n < 10) or (n > 99) then i:= 0 
else i:= 1; 
until i>0; 
a:= n mod 100 div 10; 
b:= n mod 10; 
s:= (a+b)+sqr (a+b); 
if s <> n then writeln ('Число не соотвествует условию') 
else writeln ('Число ',s, ' соответствует условию');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?