В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Kintavr12345
Kintavr12345
05.01.2021 05:38 •  Информатика

1. линейные алгоритмические конструкции. составить программу подсчета суммы элементов.

2. линейные алгоритмические конструкции. составить программу подсчета площади и объема по формулам v=abc, s=2(ab+bc+ac)

4. найти сумму элементов одномерного массива. элементы вводятся с клавиатуры.

5. найти наименьший элемент одномерного массива.

6. цикл с предусловием. вывести таблицу умножения на 9.

7. цикл с предусловием. вывести значения функции у=|х|+2 с шагом 0,5.

8. оператор множественного выбора case. составить программу, которая по букве определяет гласная она или нет.

9. составить программу, которая по номеру квартиры определяет этаж, если известно, что дом имеет 5 этажей и 4 квартиры на этаже.

10. условный оператор if. составить программу, которая удваивает число, если оно 5.

Ответ:
aiau2004
aiau2004
02.10.2020 15:13

Написал код на все задачи, кроме восьмой. Писал так, как понял условие, так что не придирайся там слишком))) Весь код ниже:

Объяснение:

{#1}

var a: array [1..100] of integer;

i,s: integer;

zn: string;

begin

s:= 0;

i:= 0;

writeln('answer on question --- |yes = +| |no = -|');

writeln('enter more? --- ');

readln(zn);

while zn = '+' do

   begin

       i:= i + 1;

       readln(a[i]);

       s:= s + a[i];

       writeln('enter more? --- ');

       readln(zn);

   end;

writeln('sum = ',s);

end.

{#2}

var a,b,c: integer;

s1, s2: real;

begin

   writeln('a = ');

   readln(a);

   writeln('b = ');

   readln(b);

   writeln('c = ');

   readln(c);

   s1:= a*b*c;

   s2:= 2*(a*b+b*c+a*c);

   writeln('s1 = a*b*c = ',s1:0:3);

   writeln('s2 = 2*(a*b+b*c+a*c) = ',s2:0:3);

end.

{#4}

var a: array [1..100] of integer;

i,s: integer;

begin

s:= 0;

   for i:= 1 to 20 do

   begin

       writeln('a[',i,'] = ');

       readln(a[i]);

       s:= s + a[i];

   end;

writeln('sum of elements = ',s);

end.

{#5}

var a: array [1..100] of integer;

i,min: integer;

begin

   for i:= 1 to 20 do

   begin

       writeln('a[',i,'] = ');

       readln(a[i]);

   end;

   min:= a[1];

   for i:= 1 to 20 do

   begin

       if a[i] < min then min:=a[i];

   end;

   writeln('minimum of elements = ',min);

end.

{#6}

var i: integer;

rez: real;

begin

rez:= 0;

   for i:= 1 to 9 do

   begin

       rez:= i*9;

       writeln(i,' * 9 = ',rez:0:0);

   end;

end.

{#7}

var y,x: real;

begin

x:= -5;

   while (x >= -5) and (x <= 5) do

   begin

       y:= abs(x) + 2;

       writeln('x = ',x:0:1,' --- y = ',y:0:1);

       x:= x + 0.5;

   end;

end.

{#8}

(8-ая не сделана)

{#9}

var num: integer;

pr,rez: real;

begin

   writeln('enter number of floor --- ');

   readln(num);

   pr:= num/4;

   rez:= round(pr);

   if pr > rez then rez:= rez + 1;

   writeln(rez:0:0,' number of floor');

end.

{#10}

var  num: integer;

begin

   writeln('enter number --- ');

   readln(num);

   if num = 5 then num:=num*2;

   writeln('number after editing --- ',num);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?