В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Агааемгов
Агааемгов
06.05.2020 10:32 •  Информатика

Напишите программу, которая принимает с клавиатуры целое число и проверяет, на какое количество двузначных чисел оно делится. результат проверки класс должен вывести на экран вместе с соответствующим текстовым сообщением.

Ответ:
дарья1645
дарья1645
02.10.2020 15:15
На паскаль
var i,j,k:longint;
begin
read(i);
if i < 10 then write('Число меньше 10. Поэтому оно не имеет двузначный делитель');
for j:=10 to 99 do
if i mod j=0 then inc(k);
if k=0 then write('Ваше число не имеет двузначный делитель') else write('Ваше число имеет ',k,' делителей');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?