В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
misszephir25
misszephir25
24.07.2021 08:56 •  Информатика

Напишите и ее решение в паскале. массивы составить программу для решения следующей : дан массив целых чисел. выяснить какой элемент массива больше, k-й или p-й.

Ответ:
Boi11
Boi11
23.07.2020 13:57
Var a,b,c:integer;
n:array [1..10] of integer;
begin
writeln('введите номера элементов для сравнения');
readln(a,b);
randomize;{скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом}
for c:=1 to 10 do begin
n[c]:=random(-20,20);{так мы в массив ставим случайное число в диапазоне от -20 до 20}
writeln(n[c]);
end;
if n[a]<n[b] then writeln('меньший элемент массива под номером ' ,a,' больший элемент массива под номером ' ,b)
else writeln('меньший элемент массива под номером ' ,b,' больший элемент массива под номером ' ,a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?