В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Хантенир11
Хантенир11
11.03.2020 01:25 •  Информатика

Написать программу, вычисляющую и сохраняющую в одномерном массиве значение функции у={x при х≤0, х² при х> 5,4 если иначе. на интервале [-10; 10] с шагом 0,5. на паскале или си/си++ заранее

Ответ:
healarcimbo
healarcimbo
23.07.2020 12:49
{41 = (20/0.5+1}}
var a:array [1..41] of real;
    h,y,x:real;
    i:integer;
begin
 x:=-10.5;
 h:=0.5;
 i:=0;
 repeat
  i:=i+1;
   y:=4;
   if x<=0 then y:=x
     else if x>5 then y:=x*x;
     a[i]:=y;
   x:=x+h;
  writeln(x:8:2,a[i]:8:2);
 until x>=10;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?