В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
svishevaarina
svishevaarina
10.12.2022 23:22 •  Информатика

Написать программу для решение - посчитать количество чисел от 1 до 1000 кратных 7 и честных ( провереть кратность 7 командой mod введя условие если в цикл)

Ответ:
Никитка90909
Никитка90909
23.07.2020 12:19
Var
   x,i,y:integer;
begin
  for i:=1 to 1000 do
    begin
      x:= i mod 7;
      if x=0 then
        begin
        y:=y+1;
        writeln (i);//строка выводит все числа кратные семи. она подлежит удалению
       end;
     end;
  writeln (y);
end.
0,0(0 оценок)
Ответ:
KVASSok
KVASSok
23.07.2020 12:19
Var
   count,i:integer;
begin
  i:=0;count:=0;
 repeat
     i:=i+2;
     if i mod 7 =0 then count:=count+1;
 until i>=1000;
 writeln(count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?