В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aiperi7
aiperi7
04.07.2020 15:04 •  Информатика

5. в двухмерном массиве хранится информация о количестве студентов в той или иной группе каждого курса инсти¬тута с первого по пятый (в первой строке — информация о группах первого курса, во второй — второго и т. на каж¬дом курсе имеется 8 групп. составить программу для расчета общего числа студентов на любом курсе. си шарп.

Ответ:
flora21345
flora21345
02.10.2020 15:05
Using System;

namespace Znanija {
    internal class Program {

        private static void Main() {
            var r = new Random(DateTime.Now.Millisecond);
            var course = r.Next(1, 6);
            var students = new int[5,8];

            for (var i = 0; i < students.GetLength(0); i++) {
                for (var j = 0; j < students.GetLength(1); j++) {
                    students[i, j] = r.Next(10, 40);
                    Console.Write("{0:d2} ", students[i, j]);
                }
                Console.WriteLine();
            }

            Console.WriteLine("На курсе {0} кол-во студентов = {1}", course, CountStudents(students, course));
            Console.ReadKey();
        }

        private static int CountStudents(int[,] students, int course) {
            if (students.GetLength(0) < course) {
                Console.ForegroundColor = ConsoleColor.Red;
                Console.WriteLine("Нет курса " + course);
                return 0;
            }

            var number = 0;
            for (var i = 0; i < students.GetLength(0); i++) {
                number += students[course - 1, i];
            }

            return number;
        }

    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?