В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aksa2101
Aksa2101
11.09.2022 18:36 •  Информатика

Написать программу перевода целого двоичного десятиразрядного числа в десятичную систему

Ответ:
Lilu700
Lilu700
02.10.2020 15:19
{
Перевод двоичного числа в десятичное.
Символы, отличающиеся от 0 и 1, заменяются нулями.
Программа будет работать некорректно при вводе
более 31 знака.
}
var
  bin:string;
  i,d:integer;
  p,dec:longint;
begin
  Write('Введите двоичное число: '); Read(bin);
  dec:=0;
  p:=1;
  for i:=Length(bin) downto 1 do
  begin
    if bin[i]='1' then d:=1 else d:=0;
    dec:=dec+d*p; p:=2*p
  end;
  Writeln('Десятичный эквивалент: ',dec)
end.

Тестовое решение:
Введите двоичное число: 1011011001
Десятичный эквивалент: 729
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?