В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tytik1
tytik1
05.12.2021 16:33 •  Информатика

Составить программу ! вот условие: даны два действительных числа x и y, не равные друг другу. заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. программа должна иметь дружественный интерфейс. на паскале

Ответ:
erke22
erke22
23.07.2020 10:51
Var x,y,t:real;
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
  t:=y;
  y:=(x+y)/2;
  x:=x*t*2;
End
else
Begin
  t:=x;
  x:=(x+y)/2;
  y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?