В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ymnik3345
ymnik3345
20.10.2021 20:53 •  Информатика

Составить программу, которая посчитает сумму натуральных чисел из промежутка от 1 до 100, которые делятся на 17 и сумма цифр, которых не превышает 7. в паскале.

Ответ:
feruza1111
feruza1111
23.07.2020 08:56
{сумма натуральных чисел из промежутка от 1 до 100,
которые делятся на 17 и сумма цифр, которых не
превышает 7. Можно перебором}
var i,s:integer;
begin
 s:=0;
 for i:=1 to 100 do
 if  (i mod 17=0) and (i div 10 + i mod 10<7) then
 s:=s+i;
 writeln(s);
end.
{результат 51}

{
Можно оптимизировать
в цикле изменив  for i:=1 to 100 do
на
 for i:=17 to 100 do}

{2 вариантө оптимальнее - перебираем только числа кратные 17]
var i,s:integer;
begin
 s:=0; i:=17;
 while i<=100 do
 begin
   if  (i div 10 + i mod 10<7) then
   s:=s+i;
   i:=i+17;
 end;
 writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?