В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
has2011
has2011
18.04.2022 05:05 •  Информатика

Написать программу для паскаль через оператор case. для целого числа k от 1 до 99 напечаать фразу "мне k лет", учитывая при этом что при вводе некоторых значений k слово "лет" надо заменить на слово "год" или "года".

Ответ:
Mariiar
Mariiar
23.07.2020 08:03
Program p1;
Var a:integer;
Begin
  Write('Введите возраст: ');
  Readln(a);
  Case a of
    11..14:Write('Мне ',a,' лет');
    else
    Case a mod 10 of
      1:Write('Мне ',a,' год');
      2..4:Write('Мне ',a,' года');
      else Write('Мне ',a,' лет');
    End;
  End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?