В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
POMIPO
POMIPO
12.08.2020 09:31 •  Информатика

Составить программу ! вот условие: разработать схему алгоритма, который вводит массив из n целых чисел и выводит на экран этот же массив в прямом и обратном порядке. протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. на паскале

Ответ:
математик215
математик215
22.07.2020 23:55
Var n,i:integer;
a:array[1..1024] of integer;
begin
randomize;

write('N=');
readln(n);

for i:=1 to n do
a[i]:=random(2*n+1)-n;

write('V pramom poradke - ');
for i:=1 to n do
write(a[i],' ');
writeln;

write('V obratnom poradke - ');
for i:=n downto 1 do
write(a[i],' ');
writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?