В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
линаким1
линаким1
02.02.2020 11:11 •  Информатика

Программирование в си++ ! нужно написать программу, в которой 2 переменные типа float в main() являются локальными, а после используются в функции, которая вычисляет квадраты этих чисел. , исправьте мои ошибки. #include #include #include #include int function(float *pointer1, float *pointer2) { float ch1, ch2; ch1 = powf(*pointer1, 2); ch2 = powf(*pointer2, 2); printf_s("квадрат первого числа равен: %f\n", ch1); printf_s("квадрат второго числа равен: %f\n", ch2); system("pause"); return(0); } int main() { setlocale(lc_all, "rus"); float a, b; float *pointer1; float *pointer2; printf_s("введите первое число: "); scanf_s("%f", & a); printf_s("введите второе число: "); scanf_s("%f", & b); pointer1 = & a; pointer2 = & b; function(& a,& b); } + напишите программу с возвратом значений

Ответ:
Танзила44
Танзила44
02.10.2020 14:37
Можно вот так, например (проверено в Dev C++):

#include <iostream>
#include <cmath>
using namespace std;
int function(float *pointer1, float *pointer2)
{
float ch1, ch2;
ch1 = powf(*pointer1, 2);
ch2 = powf(*pointer2, 2);
cout<<"Квадрат первого числа равен:"<<ch1<<endl;
cout<<"Квадрат второго числа равен:"<<ch2<<endl;
return(0);
}

int main()
{
setlocale(LC_ALL, "RUS");
float a, b;
float *pointer1;
float *pointer2;
cout<<"Введите первое число:";
cin>>a;
cout<<"Введите второе число:";
cin>>b;
pointer1 = &a;
pointer2 = &b;
function(&a,&b);
system("PAUSE");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?