В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Реализовать с 3-х циклов: while, repeat, for) составить программу, которая выдавала бы сообщение ‘ true ‘, если последовательность из n целых чисел, вводимых с клавиатуры, является возрастающей

Ответ:
matveykatvey13
matveykatvey13
02.10.2020 14:34
Это реализовано с цикла for:

Program p1;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
For i:=0 to 1 do   
Begin   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
End;
if k=2 then 
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.

Это реализовано с цикла while:

Program p2;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
While i<>2 do   
Begin   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
i:=i+1;   
End;
if k=2 then Writeln('Эта последовательность является возрастающей') else Writeln('Эта последовательность не является возрастающей');
End.

Это реализовано с цикла repeat:

Program p3;
Var a1,a2,k,i:integer;
Begin
Write('Введите число: ');
Readln(a1);
repeat   
Begin   
i:=i+1;   
Write('Введите число: ');   
Readln(a2);   
if a2>a1 then    
k:=k+1;   
a1:=a2;   
End;
until i=2;
if k=2 then 
Writeln('Эта последовательность является возрастающей') else
Writeln('Эта последовательность не является возрастающей');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?