В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kateshafran1234
kateshafran1234
24.11.2020 04:01 •  Информатика

Программа в паскаль написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.

Ответ:
Grif69
Grif69
02.10.2020 14:28
//Написать программу, которая упорядочивает цифры в заданном пятизначном числе по убыванию.

var a:array[1..5] of integer;
x,i,j:integer;
begin
  Writeln('Введите пятизначное число');
  Readln (x);
  while  (x<9999) or (x>99999) do  // проверка числа на "пятизначность"
    begin
      writeln ('Вы ввели не пятизначное число попробуйте еще раз');
      readln (x);
    end;
  for i:=1 to 5 do //раскладываем число на отдельные цифры
    begin
      a[i]:=x mod 10;
      x:=x div 10;
    end;
    for j:=1 to 4 do //сортировка пузырьком
      begin
        for i:=1 to 4-j do
          begin
            if a[i]>a[i+1] then
              begin
                x:=a[i];
                a[i]:=a[i+1];
                a[i+1]:=x;
              end;
          end;
      end;
   for j:=1 to 5 do write (a[j]);//вывод результата
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?