В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
manawer
manawer
02.05.2023 22:54 •  Информатика

Напишите программу, которая для заданной точки с координатами (х,у) определяет, где она расположена: на какой оси или в какой координатной четверти

Ответ:
natakleymyk
natakleymyk
22.07.2020 21:26
Pascal

 var   
x,y : integer;    
begin 
readln (x,y); 
if (x=0) or (y=0)
then   
begin   
if x = 0 then
     writeln ('Точка лежит на оси y');   
if y = 0 then
     writeln ('Точка лежит на оси x')'   
end 
else 
 begin 
   if (x>0) and (y>0) then
     writeln ('Точка находится в первой четверти'); 
   if (x<0) and (y>0) then
     writeln ('Точка находится во второй четверти'); 
   if (x<0) and (y<0) then
     writeln ('Точка находится в третей четверти'); 
   if (x>0) and (y<0) then
     writeln ('Точка находится в четвертой четверти');
  end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?