В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
strelkina42
strelkina42
27.05.2022 11:04 •  Информатика

Написать программу в pascal числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)

Ответ:
Kari200511
Kari200511
22.07.2020 20:16
Уверен, что формула в условии написана неверно, но уж как написано...

var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31

А вот так, на мой взгляд, должно быть:
var
  a,b,c:real;
begin
  Write('Введите a,b,c: '); Read(a,b,c);
  Writeln('Результат: ',(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6
0,0(0 оценок)
Ответ:
Patsanchik999
Patsanchik999
22.07.2020 20:16
Function max (var first,second:real): real;
begin 
if first > second then max:=first else max:= second;
end;

var a,b,c,y : real;
begin 
writeln('Ведите a,b,c через пробел и нажмите Enter: '); 
 read(a,b,c); 
y:= max(a,a+b)+max(a,b+c)/1+max(a+b*c,1.5); 
 writeln('ответ: ',y);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?