В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alyonaSidorenk
alyonaSidorenk
19.05.2020 21:43 •  Информатика

Напишите программу на паскале. дан массив положительных и отрицательных чисел. вычислить сумму положительных и произведение отрицательных чисел. а[1..10]

Ответ:
Mrkronomax
Mrkronomax
02.10.2020 14:05
Const m=10;
var
a:array[1..m] of integer;
i,sum,proz:integer;
begin
sum:=0;
proz:=1;
for i:=1 to m do
begin
read(a[i]);
if a[i]>0 then
sum:=sum+a[i]
else
ifa[i]<0 then
proz:=proz*a[i];
end;
writeln('Сумма положительных чисел= ',sum,' Произведение отрицательных чисел= ',proz);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?