В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
irinazakharova1
irinazakharova1
13.05.2021 23:45 •  Информатика

Pascal. 1.определить количество слов в предложении. 2.определить какая буква в строке встречается чаще: первая или последняя. 3. написать программу меняющую слово "петр" на "иван".

Ответ:
alinkass
alinkass
22.07.2020 15:24
Для подсчёта слов в предложении, вот код:

program Slova;
var
 s: string;
 r,i:integer;
begin
 writeln('Введите ваше предложение');
 readln(s);
 s:=s+' ';
 for i:=1 to length(s)-1 do
 if (s<>' ') and (s[i+1]=' ') then
 r:=r+1;
 writeln('В предложении ',r, ' слов. ');
 readln;
end.

Какая буква встречается чаще

Program Bykv;
Var s:String;
    i,k1,k2:byte;
Begin
    write('Введите строку: ');readln(s);
    For i:=2 to Length(s)-1 do
     if s[i]=s[1] then inc(k1)
      else if s[i]=s[Length(s)] then inc(k2);
    writeln('Первая буква встречается ',k1);
    writeln('Последняя буква встречается ',k2);
    writeln('Вывод:');
    if k1>k2 then writeln('Первая буква встречается чаще')
     else if k1<k2 then
     writeln('Последняя буква чаще')
      else writeln('Одинаково');
    readln;
End.

Изменить слово петя на иван в строке

program test;
var s,t,z,p:string;j:integer;
begin
writeln('Введите ваше предложение');
readln(s);
write('Введите слово которое хотите заменить: ');
readln(t);
write('Введите замену слову: ', t, ' <> ');
readln(z);
if pos(t,s)<>0 then
j:=pos(t,s);
p:=copy(s,1,j-1);
p:=p+z;
p:=p+copy(s,j+length(t),length(s));
writeln(p);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?