В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ewa11
Ewa11
04.01.2023 19:47 •  Информатика

Дано четырехзначное число. написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.

Ответ:
mkudryavceva10
mkudryavceva10
26.05.2020 03:30

program a1;
var
a,b,c,r:byte; l,k:word;
begin
read(l);
a:=l mod 10;
b:=l div 10 mod 10;
c:= l div 100 mod 10;
r:= l div 1000 mod 10;
k:=c*1000+r*100+a*10+b;
write(k); end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?