В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
21.04.2020 16:56 •  Информатика

Впаскале написать программу: ) найти сумму чётных чисел от 2 до 21 нужно три зарание : )

Ответ:
ясин9595
ясин9595
22.07.2020 14:47
type
   massiv = array [2..21] of integer;
var
    mass : massiv;
    i, summa : integer;
 
begin
   summa := 0;
   for i:=2 to 21 do
        begin
           mass[i]:=i;
           if (mass[i] mod 2 = 0) then
              summa := summa + mass[i]
        end;
   writeln('Сумма четных эл-тов равна : ', summa);
   readln;
end.

program z;
var
        a : array[2..21] of integer;
        i,summ : integer;
        b : array[2..21] of integer;

begin
        for i:= 2 to 21 do
        begin
         a[i]:=i;
        end;

        for i:=2 to 21 do
          begin
          if a[i] mod 2 = 0 then
                begin
                  b[i]:=a[i];
                end;

          end;

        summ:=0;
        for i:=2 to 21 do
        begin
         summ:=summ+b[i];
        end;
        Writeln(summ);
        readln;

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?