В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. определить число членов суммы. значение суммы и число ее членов вывести на экран с соответствующими комментариями.

Ответ:
vikylev011
vikylev011
22.07.2020 13:13
Вроде получилось:

var a,b,s:integer; 
begin
write('Числа = ');
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,', ');
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln('Сумма чисел = ', s);
end.

Результат:

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор,
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?