В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Litsonchik
Litsonchik
05.04.2021 05:13 •  Информатика

Дано условие и программа, ее решающая. предложить набор тестов для проверки работо программы. составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: 1. треугольник со сторонами a, b, c является равносторонним. var a, b, c : integer; begin writeln(' a, b, c? '); readln(a, b, c); writeln( (a=b) and (b=c) and (a=c) ) end.

Ответ:
ndjfhfidi
ndjfhfidi
22.07.2020 12:14
1) вводить три равных натуральных числа - треугольник равносторонний. Результат программы TRUE ⇒ программа работает корректно
2) вводить три неравных натуральных числа - треугольник не равносторонний. Результат программы FALSE ⇒ программа работает корректно

3) ввести три нуля - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
4) вводить три равных отрицательных числа - треугольник не существует. Результат программы TRUE ⇒ программа работает некорректно
5) ввести три равных или неравных вещественных числа - треугольник существует. Результата программы нет (ошибка типов) ⇒ программа работает некорректно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?