В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MILAVASSILYEVA
MILAVASSILYEVA
08.01.2023 07:31 •  Информатика

Дан массив из 10 элементов. составить программу, находящую среднее арифметическое положительных.

Ответ:
solopova08
solopova08
02.10.2020 13:24
Program mass;
uses crt;
var massiv:array[1..10] of integer;
     i,count:integer;
     sra:real;
begin
for i:=0 to 10 do begin
   readln(massiv[i]);
   if massiv[i] > 0 then begin
     count:= count+1;
     sra:= sra + massiv[i];
  end;
end;
sra:= sra/count;
writeln('Среднее арифметическое = ',sra);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?