В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AlbertWasHere
AlbertWasHere
04.02.2021 03:52 •  Информатика

Написать программу,которая в одномерном массиве из 15 элементов подсчитывает количество элементов равных среднеарифметическому

Ответ:
МухаВж
МухаВж
22.07.2020 07:09
Uses crt;
const
n=15;
var
a:array[1..n]of real;
i,k:integer;
s:real;
begin
for i:=1 to n do
    begin
      readln(a[i]);
      s:=s+a[i];
    end;
s:=s/n;
writeln;
clrscr;
for i:=1 to n do
   begin
    write(a[i]:6:2);
       if a[i]=s then
           inc(k);
   end;
writeln;
if k<>0 then
   writeln('k: ',k)
else writeln('Нет равных')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?