Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
МашаИвлеева789
06.12.2020 15:07 •
Информатика
Написать программу, которая выведет 4 первые четных числа(2,4,6,8) и написать программу которая находит сумму этих чисел.
Ответ:
NastyaVait3
02.10.2020 13:12
У меня вот так вышло, хотя можно еще несколькими сделать эту задачу
int main()
{
int mass[10]; //оглашаем массив из 10 целых чисел(или сколько захотите сами)
//как заполнить массив решите сами
int temp[4];//массив который будет хранить 4 четных элемента
int flag=0;
int j=0;
for(int i=flag;i<10;++i)
{
if(mass[i]%2)temp[j]=mass[i];
flag=i;
++j;
}
int Sum=0;
for(int j=0;j<4;++j)
{Sum+=temp[j];
cout<<temp[j]<<"\n";
}
cout<<Sum;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
снегурочка98
13.02.2020 07:14
Составить программу по basic 15...
Света11111111119079г
21.02.2020 21:56
Какую информацию несет строка : l1.txt 1 кб текстовый документ 02.03.2007.18: 00...
Настуушка
21.02.2020 21:56
Задан массив из 10 случайных целых чисел от 0 до 50 . увеличить в 2 раза элементы массива кратные 5, остальные элементы массива уменьшить в 2 раза....
рикки8
03.08.2022 03:42
Какая по твоему мнению была цель моделирования то есть создание этой графической модели вставь пропущенные слова и ответь верное...
мороженле
12.05.2022 08:12
Ипполит задумал трехзначое число которое при деление на 15 даует в остатке 11 а при делелии на 11 дает в остатке 9 (ПИТОН) желательно сделать не очень умно, ведь некоторые фунцкии...
selenkovaanasta
30.05.2022 18:22
Можете всё сделать на картинки а не текстом естестзнанию соч...
izibaevsergei
14.03.2021 18:52
К какому виду относится данный робот? Напишите область применения данного робота ...
karakozkirikbaox8y6c
14.03.2021 18:52
1. Если сумма квадратов двух чисел равна 117, а сумма двух чисел равна 15. Найдите эти числа....
гугуляга
14.03.2021 18:52
Заранее большое : ) Решите неравенства: 6(х-1,5) +6 4х – 3...
артbig
22.01.2021 22:44
Прочитайте отрывок из повести Л. Толстого «Кавказский пленник» и придумайте заголовок, отражающий основную мысль эпизода. Прибежала девочка по имени Дина - тоненькая, худенькая,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main()
{
int mass[10]; //оглашаем массив из 10 целых чисел(или сколько захотите сами)
//как заполнить массив решите сами
int temp[4];//массив который будет хранить 4 четных элемента
int flag=0;
int j=0;
for(int i=flag;i<10;++i)
{
if(mass[i]%2)temp[j]=mass[i];
flag=i;
++j;
}
int Sum=0;
for(int j=0;j<4;++j)
{Sum+=temp[j];
cout<<temp[j]<<"\n";
}
cout<<Sum;
}