В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
MDA142rus
MDA142rus
06.05.2022 20:20 •  Информатика

Паскаль пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента. определите наибольшее число последовательности.

Ответ:
chuvataeva
chuvataeva
21.07.2020 23:58
Попробуй так:

uses Crt;
var a, Max: real;
    i: integer;
begin
ClrScr;
i:=0;
Repeat
  i:=i+1;
  Write ('a',i,'='); ReadLn (a);
  if a<>0 then
      begin
        if a>Max then Max:=a;
      end;
  until a=0;
WriteLn;
WriteLn(' Max = ', Max:6:4);
ReadLn;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?