Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
furymalice
03.01.2023 11:00 •
Информатика
7. дан массив а из 20 элементов. заменить отрицательные эле-менты массива на среднее арифметическое элементов массива. результат вывести на печать.
Ответ:
Gesha11
21.07.2020 22:44
Var Sr:real;
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.
0,0
(0 оценок)
Популярные вопросы: Информатика
жenya
26.02.2021 19:13
3. два текста содержат одинаковое количество символов. первый текст составлен в алфавите мощностью 8 символов, а второй текст – в алфавите из 512 символов. во сколько раз количество...
Puma20050412
30.05.2020 11:19
(ПАСКАЛЬ)Напишите программу которая 20раз выводит на экран Ваше имя и фамилию в столбик...
Умняшаааа145
01.12.2020 03:50
1.что вы понимаете под программным обеспечением компьютера? 2.для чего нужна операционная система? как называется операционная система,установленная на ваших компьютерах? 3.какие...
lyuda29m
01.12.2020 03:50
Составьте программу на языке паскаля для нахождения площади круга по диаметру ....
Ekaterinakozlik
27.06.2020 20:25
Можно ли быть одновременно объектом и объектом? если да,то пример...
seminalydmila
17.09.2022 09:14
Вычислить объем файла в Килобайтах, если изображение состоит из 120*710 точек и глубина цвета равна 18? В ответе записать только целое число...
dan4280
30.09.2020 12:48
Солнце - это не, а) раскалённый газовый шар б) самая большая звезда вселенной в) центр солнечной системы...
NurlG
30.09.2020 12:48
Груз массы 4 кг находится на столе. стол движется горизонтально с ускорением 3 м/с. к грузу присоединена нить, перекинутая через блок, расположенный на краю стола. к другому...
misterbory
30.09.2020 12:48
Лодка отплыла то пристани по реке, которая течет со скоростью 3,2 км/ч. будет ли двигаться лодка и в какую строну, если она поплывет: 1) по течению со скоростью 4,5 км/ч; 2)...
Lala0911
30.09.2020 12:48
Характер ательстана в романе вальтера скотта айвенго ....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,n:integer;A:Array[1..20] of real;
beginfor i:=1 to 20 do begin
A[i]:= random(100)-50;
write(A[i]:5);
Sr:= Sr + A[i];
end;
Sr:= Sr/20;
Writeln(' Sr= ', Sr);
for i:=1 to 20 do begin
if A[i] < 0 then A[i]:= Sr;
write(A[i]:5);
end;end.