В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
daurmukhtar99
daurmukhtar99
30.04.2021 21:42 •  Информатика

Напишите программу pascal в циклическом алгоритме. : определить,являются ли подобными 2 треугольника,если известны длины всех 3-х сторон каждого треугольника.

Ответ:
79654622969ss
79654622969ss
21.07.2020 20:53
Var a:array[1..2,1..3] of integer;
i,i1,i2,k:integer;
z:real;
begin
writeln('Vvedite storoni treugolnikov');
for i1:=1 to 2 do
for i2:=1 to 3 do
read(a[i1,i2]);
for i1:=1 to 3 do
for i2:=1 to 3 do
begin
if  a[1,i1]>a[1,i2] then
begin
k:=a[1,i2];
a[1,i2]:=a[1,i1];
a[1,i1]:=k;
end;
if  a[2,i1]>a[2,i2] then
begin
k:=a[2,i2];
a[2,i2]:=a[2,i1];
a[2,i1]:=k;
end;
end;
z:=a[1,1]/a[2,1];
for i2:=1 to 3 do
if a[1,i2]/a[2,i2]=z then i:=i+1;
if i=3 then writeln('da') else writeln('net');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?