Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Karina3589
05.02.2021 09:09 •
Информатика
С) turbo pascal составить программу к : 'числа a,b и c называются "пифагоровой тройкой",если выполняется условие a*a+b*b=c*c отыщите все пифагоровы тройки среди чисел от 1 до n
Ответ:
Vika2471
02.10.2020 12:56
Вот решение за O(n^3)
var
n,i,j,z:longint;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
for z:=1 to n do
if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
lizochkascherb
10.02.2020 14:14
Какие минусы и плюсы на сайтах: SHEIN и нужно...
BEM007
08.05.2022 04:33
Агент 007 получил информацию о том, что секретный код от сейфа с важными материалами – это самое маленькое натуральное число, делящееся на 30 такое, что сумма его цифр тоже...
Romangritsak13
21.10.2022 04:41
Какой будет формула после копирования (1) Д4:=2*F3+$B5= F6 (2) F16:=(Д$2-F12)*$H9= Д12 (3) AZ37:=5*AA24+ВД17= AX25...
MGap58
07.07.2020 05:01
Дан массив А, который состоит из таких чисел: 5; 23; 1; 12; 8. опредилите результат выполнения фрагмента программы S:=0; For i:= 1 to 5 do lf A[i] =8 Then S:= S+A[i]; a) 3...
tony23
07.07.2020 05:01
Таблицу истинности построить: F=A*(A+B)...
chestnut3342
18.12.2020 11:24
написать правильно функцию. Дам 35(информатика 1 курс, иксель)...
mishanyak19991
17.04.2023 03:44
. Вычислите и сравните выражения: 101, 101,2+102112 и ...
MashaZhukova12345
09.05.2020 00:58
Составьте программу: по возрасту определить социальную роль человека. ...
voicehovakseneлеля
17.01.2020 17:26
Help me with English please...
Smillekate
03.11.2021 02:22
Английский язык 5 класс 2 3 задание ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
n,i,j,z:longint;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
for z:=1 to n do
if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.