В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mrfreeman26p0aanr
mrfreeman26p0aanr
08.04.2022 23:54 •  Информатика

Написать программу на паскале где надо найти сумму чисел из отрезка от а до б, кратным 7 и вывести числа на печать в строчку цикл с шагом -1 то есть down to

Ответ:
lanaruden
lanaruden
21.07.2020 17:33
Var

var
a,b,i:integer;
begin    
readln(a,b);
if a>b then
  begin
     for i:=a downto b do
            if i mod 7= 0 then
                  write(i:4) 
   end
else
        for i:=b downto a do
             if i mod 7= 0 then
                  write(i:4) ;
end.

    
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?