Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Еленаелец77
15.01.2020 07:14 •
Информатика
Не могу написать программу на языке паскаль, , кто как может. заполнить массив из 12 чисел случайными числами в интервале [-12..12] и выполнить инверсию для каждой трети массива. 15 за лучший
Ответ:
stas7454
21.07.2020 16:26
Если решать на ПаскалЕ, то вот так:
program palindrom;
var
n, s: string;
i: integer;
b: boolean;
begin
readln(n);
for i:=1 to 4 do
s=n[5-i];
if s=n then b:=True else b:=False;
writeln(b);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
palieva69
28.08.2022 00:53
Что выведет программа? a = True b = True if a and b: print(1) else: print(2)...
89622356703
28.08.2021 02:07
Запишите следующее выражение на языке Python у меня сор ...
Appledog
09.03.2023 03:30
Какие действия над записями базы данных приводят к изменению её состава?...
bsvetlana760
16.12.2022 00:26
Соствить в паскале, с клавиатуры вводился пятизначное число.вывести на экран да ,если сумма его цифр кратно 7,а произведение цифр меньше 100,в противном случаи нет...
Chumaeva79
05.10.2022 04:49
Разрешение экрана монитора 352×288 означает, что изображение на его экране будет состоять из точек в каждой строке....
жанна19882
26.01.2021 01:42
Точки а и в расположены по разные стороны от прямой а ,точка с∉а. является ли точка с точкой пересечения прямых ав и а ,если точка с∉ав? вопрос на 10 .отмечу как лучший...
Лилия2552
26.01.2021 01:42
Как перевести обыкновенную дробь в десятичную...
SerenaWilliamsisa
08.02.2023 11:46
Север, запад, восток горизонт какие общие грамматические признаки...
max438073
06.05.2022 14:36
Делать в packal abc! составить программу, реализующую диалог компьютера с пользователем. программа запрашивает у пользователя его имя и выводит фразу типа «, ! » 3. составить программу...
max50chepil
06.05.2022 14:36
Измени форму слова и выдели оканчания,запиши через запятую: 1)белочка,в дупле,нв дереве,у окна,журавли, 2 класс...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program palindrom;
var
n, s: string;
i: integer;
b: boolean;
begin
readln(n);
for i:=1 to 4 do
s=n[5-i];
if s=n then b:=True else b:=False;
writeln(b);
end.