В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
povorovak
povorovak
11.04.2021 07:59 •  Информатика

Спрограммами по 1)дано натуральное число n. составьте программу, которая определяет сколько цифр этого числа кратны 3. 2)даны натуральные числа n, .составьте программу, которая определяет количество членов последовательности , являющихся нечетными числами.

Ответ:
Владивостокер
Владивостокер
02.10.2020 12:27
 1)
var   
a,b,k : integer;  
begin 
readln (a);   
k := 0;     

While a > 0 do   
begin     
b := a mod 10;     
a := a div 10;     
if b mod 3 = 0 then       
k := k +1; 
end;   

writeln (k); 
end.

2)
 var   
n,a,i,k : integer;    
begin 
readln (n);   
k := 0;   
for i := 1 to n do   
begin     
readln (a);     
if a mod 2 = 1 then       
k := k +1;   
end;     
writeln (k); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?