В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ElenaBorova
ElenaBorova
17.10.2021 15:22 •  Информатика

Составить программу в pascal abc ,которая из заданной строки получала бы новую строку ,удалив все "#" и повторив каждый символ ,отличный от знака решотка дважды. вывести на экран ,полученную новую строку.

Ответ:
Лера568687
Лера568687
26.05.2020 02:23

var a:string;
i,j:integer;
begin
readln(a);
while pos('#',a)<>0 do delete(a,pos('#',a),1);

for i:=1 to length(a) do
for j:=1 to 2 do
write(a[i]);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?