В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
eldos4
eldos4
20.05.2020 05:17 •  Информатика

Программирование в pascal) надо написать программу. 1.n=20 определить сумму отрицательных элементов массива. 2.сдвинуть элементы массива на одну позицию вправо, последний элемент переместить на первое место. 3.все положительные элементы исходного массива записать во второй массив, все отрицательные элементы – в третий массив.

Ответ:
DEH111
DEH111
02.10.2020 12:24
1. 
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do begin
readln(o[i]);
if o[i]<0 then a:=a+o[i];
end;
writeln(a);
end.

2.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do readln(o[i]);
a:=o[n];
for i:=n-1 downto 1 do o[i+1]:=o[i];
o[1]:=a;
for i:=1 to n do  write(' ',o[i],' ');
end.

3.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
P:array[1..n] of integer;
M:array[1..n] of integer;
begin
for i:=1 to n do begin
readln(o[i]);
if o[i]>0 then p[i]:=o[i];
if o[i]<0 then m[i]:=o[i];
end;
for i:=1 to n do write(' ',o[i],' ');
writeln;
for i:=1 to n do
if p[i]<>0 then
write(' ',p[i],' ');
writeln;
for i:=1 to n do  
if m[i]<>0 then
write(' ',m[i],' ');
writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?