Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
amirgrossman
05.07.2021 07:51 •
Информатика
11 класс, проходим основы программирования на языке паскаль. учитель задал эту , не представляю как сделать по ней нужную программу, . даны 2 катета, значение которых вводится с клавиатуры. найти гипотенузу и площадь прямоугольного треугольника
Ответ:
yadron54
21.07.2020 12:06
Program prog;
uses crt;
var
a,b,c,s:real;
begin
write('катет a = ');
readln(a);
write('катет b = ');
readln(b);
writeln;
c:=sqrt(sqr(a)+sqr(b));
s:= (a*b)/2;
writeln('Гипотенуза с = ', c:0:3);
writeln('S = ', s:0:3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Artem152006
26.07.2021 20:16
Вычислить квадратный корень из суммы квадратов четных элементов в визуал-бейсике....
Kss140916
26.07.2021 20:16
Как записать на языке visual basic (cos пх)?...
1010ВАДИМ
06.11.2020 04:56
Люди добрые, , экран компьютера может поддерживать 16 цветов и отображать на экране 640 точек по горизонтали и 350 точек по вертикали. определить разрешающую экрана, количество...
olya1234567890r
06.11.2020 04:56
Напишите программу, вычисляющую сумму квадратов простых чисел в промежутке (m; n);...
Eduardo0192837465
06.11.2020 04:56
Нужна блок схема к следующим алгоритмам на паскаль школьная работа 4. var i: longint; begin for i: =100 to 999 do if (i mod 7)=0 then writeln(i); end.5.var i,s: longint;...
rybakovjaroslav
19.05.2021 00:21
Python Сколько раз выполняется заданный цикл? n=98 while n 10: n//=5...
sisennova03
09.06.2021 00:28
Тест в полном объёме тест по информатике, тема: обработка графической информации вариант 1 1. к устройствам графической информации относятся: а) принтер б) монитор в) мышь...
Maruua1
12.04.2023 02:21
Для чего в большей степени применяют растровые редакторы: для создания или для обработки изображения?...
DeNiSNoNs
13.04.2021 18:31
Составили пример из символов,где треугольник означает отнять,а ромбик прибавить.какое число получится после выполнения всех действий? начинать с числа 5. 5-треуг-4-ромб-3-ромб-6-треуг-2-треуг-1...
MOJH
13.04.2021 18:31
По информатике . запишите в pascale 4. дано целое число а. определить делиться ли число а на 3. (используем метод последовательного вычитания чисел). 5. дано целое число...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var
a,b,c,s:real;
begin
write('катет a = ');
readln(a);
write('катет b = ');
readln(b);
writeln;
c:=sqrt(sqr(a)+sqr(b));
s:= (a*b)/2;
writeln('Гипотенуза с = ', c:0:3);
writeln('S = ', s:0:3);
end.