В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nastyaorinozl1jy
nastyaorinozl1jy
10.01.2023 22:05 •  Информатика

Составить программу вычисляющую площадь произвольного треугольника со сторонами a b c в программе pascal

Ответ:
Yalikhan
Yalikhan
21.07.2020 11:59
Program prog;
uses crt;
var
a,b,c,s,p:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
write('c = ');
readln(c);

if (a>0) and (b>0) and (c>0)  then
begin
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('S = ',s:0:3);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?