Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
chapllinshow
17.07.2022 07:40 •
Информатика
Задан числовой массив, состоящий из 9 элементов. найти и вывести на экран произведение всех элементов, меньших максимального.надо составить программу.,
Ответ:
57338888
21.07.2020 11:54
Program programma;
uses crt;
var
a:array[1..100]of integer;
i,max,p:integer;
begin
clrscr;
p:=1;
for i:=1 to 9 do
begin
write('a[',i,'] = ');
readln(a[i]);
end;
for i:=1 to 9 do
begin
if a[i]> max then max:=a[i];
end;
for i:=1 to 9 do
begin
if a[i]<> max then
p:=p* a[i]
end;
writeln;
writeln('max = ', max);
write('P = ',p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Vlipli779
16.03.2020 20:03
Всем ! мне .умоляю вас! 1)определи основание числа [tex]101101010_{2}[/tex] 2)переведи число [tex]2043_{8}[/tex] в десятичную систему счисления. 3)запиши число 12496...
МахаХей
17.01.2021 03:08
Синквеин к слову информация?...
nikita1197
23.01.2021 11:51
Нужно 5 примеров, по этой таблице очень надо. Тема моделирование, 9класс...
zhasbaevamp06rkz
08.07.2022 20:52
Что делать не чего не работает. В ворде не могу вставить фото не написать текст...
Елис13
02.05.2020 23:00
Цикл для . написать программу 1)найти сумму квадратов целых чисел от 1 до 100....
54женек4
02.05.2020 23:00
Исправь ошибки и напиши что получиться на экране...
workout7774
02.05.2020 23:00
Написать программу в паскаль написать водный корабль, человек,звезда...
layzor
24.09.2021 07:48
Соотнесите что относится к Системному ПО, Прикладному ПО и к Системе программирования. 1. Ландшафтные дизайнеры создают проект нового городского ландшафта. 2.профессиональный...
kononova2007
28.02.2023 12:12
Чем является S? 4 слова. даже первые буквы слов даны, а понять не могуинформатика, 8 класс...
mazurok3
05.03.2021 22:22
С ИНФОРМАТИКОЙДАЙТЕ ТОЧНЫЙ ОТВЕТ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var
a:array[1..100]of integer;
i,max,p:integer;
begin
clrscr;
p:=1;
for i:=1 to 9 do
begin
write('a[',i,'] = ');
readln(a[i]);
end;
for i:=1 to 9 do
begin
if a[i]> max then max:=a[i];
end;
for i:=1 to 9 do
begin
if a[i]<> max then
p:=p* a[i]
end;
writeln;
writeln('max = ', max);
write('P = ',p);
end.